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Понимание процесса
Существует 3 варианта получения конечного результата:

1. Простой: данные из RVScanner напрямую экспортируются в стороннее 
ПО.

2. Продвинутый: данные из RVScanner экспортируются в ICP3, где 
производится глобальная сшивка и базовая обработка, после чего группа 
STL-файлов экспортируется в стороннее ПО, где строится единая модель 
и затем редактируется.

3. Все в ICP3: От 2-го варианта отличается тем, что единая модель тоже 
строится в ICP3, стороннее ПО используется только для дополнительного 
редактирования.

ВАРИАНТ 1: ПРОСТОЙ ВАРИАНТ 2: 
ПРОДВИНУТЫЙ

ВАРИАНТ 3: 
ВСЕ В ICP3

1 Экспорт из RVScanner 
в STL

Экспорт из RVScanner 
в X (ICP3)

Экспорт из RVScanner 
в X (ICP3)

Стороннее ПО ICP3 ICP3
2 Удаление лишних 

участков
Удаление лишних 
участков

Удаление лишних 
участков

3 Глобальная сшивка Глобальная сшивка Глобальная сшивка
4 Построение единой 

модели
Опция:
Обрезка краев

Опция:
Обрезка краев

5 Редактирование:
Упрощение
Зашивка дыр и т.д.

Опция:
Упрощение 
фрагментов

Опция:
Упрощение 
фрагментов

6 Сохранение 
фрагментов в группу 
STL-файлов

Резервное сохранение в 
X-файл

Стороннее ПО
7 Построение единой 

модели
Построение единой 
модели

8 Редактирование:
Упрощение
Зашивка дыр и т.д.

Сохранение  модели в 
STL-файл

Стороннее ПО
9 Редактирование:

Упрощение
Зашивка дыр и т.д.

Примечание
Обязательно попробуйте все варианты: использование ICP3 зачастую 
дает результат лучше.
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Экспорт из RVScanner
Чтобы сохранить модели, в RVScanner выберите Файл → Экспорт результата.

Параметры экспорта:

Обрезка краев – обычно на краях скана присутствуют небольшие артефакты, 
которые можно автоматически удалить, обрезав край каждого скана.
Упростить  с  точностью –  при  выборе  этого  режима  количество 
треугольников в каждом скане будет уменьшено в соответствии с выбранным 
критерием  точности  (чем  больше  число,  тем  меньше  треугольников 
останется).  Данная  возможность  полезна  для  моделей  с  большим  числом 
треугольников.
Сохранить как:

1. STL – экспорт в формате STL для сторонних программ.
2. X – экспорт в формате X для ICP3.

Результат будет сохранен на диск в папку _Export внутри проекта.

Внимание!
Файлы в папке проекта – всегда не сшитые.
Сшитые файлы сохраняются только в «_Export».
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Интерфейс ICP3: основы

Внимание!
Перед началом работы в программе RVScanner, отключите заставку 
Windows, а также спящий и ждущий режим.
Для пользователей с операционной системой Windows 7 может 
потребоваться запуск программы от имени администратора. Для 
этого необходимо нажать правой кнопкой мыши значок RVScanner и 
выбрать пункт Запуск от имени администратора.
В Windows 7 также рекомендуется понизить уровень контроля 
учётных записей:

1. Выберите меню Пуск → Панель управления.
2. В списке Просмотр выберите пункт Крупные значки или 

Мелкие значки.
3. Выберите раздел Учетные записи пользователей, затем 

Изменение параметров контроля учетных записей.
4. Сдвиньте ползунок вниз и нажмите OK. (Выберите положение 

ползунка, при котором RVScanner работает корректно в вашей 
системе.)

Внимание!
Обязательно сохраняйтесь после важных операций, в программе 
нет автосохранения, и отката.

Простое перемещение вокруг модели

Примечание
Это режим просмотра по умолчанию.

Внимание!
Перемещение вида (камеры) и объекта – разные операции. 
Перемещение вида не влияет на настоящие координаты объекта, а 
перемещение объекта – влияет.
В данном разделе объясняется, как двигать камеру. Перемещение 
объекта описано позже.
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Действие Перетащите вид с нажатой…

Вращение модели Левой кнопкой мыши

Перемещение модели в плоскости 
экрана

Средней кнопкой мыши (нажать 
колесико мыши)

Одновременно левой и правой 
кнопками мыши

Приближение/Удаление Правой кнопкой мыши

Инструменты выделения

Выделение прямоугольником

Выделение кистью

Результат выделения Режим выделения

По-умолчанию
выделения складываются

+ Ctrl
Новое выделение удаляет предыдущее

+ Shift
При новом выделении предыдущие 
сбрасываются.

Примечание
Для того чтобы сбросить выделение, кликните мышью + Shift в 
пустой зоне сцены.
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Выделение объектов в списке

Выделить несколько объектов в списке можно двумя способами:

• непрерывный диапазон – выделите первый объект диапазона, затем 
зажмите Shift и щёлкните по последнему необходимому объекту;

• отдельные объекты – выделите первый объект, зажмите Ctrl и по 
одному выделите остальные.

Перемещение объектов

Внимание!
Перемещение вида (камеры) и объекта – разные операции. 
Перемещение вида не влияет на настоящие координаты объекта, а 
перемещение объекта – влияет.
В данном разделе объясняется, как двигать объекты. Перемещение 
виртуальной камеры описано ранее.

Переместить объект можно с помощью окна Navigation window:

В нём есть три элемента:

1. Перетаскивая этот элемент, вы будете двигать объект в плоскости экрана.

2. Перетаскивая эти элементы (шар и кольцо), вы будете вращать объект.

3. Перетаскивая этот элемент, вы будете двигать объект дальше/ближе от 
точки просмотра (от себя).

Чтобы показать или спрятать Navigation window, выберите меню Show → 
Show/Hide navigation window.
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Основные функции ICP3

Загрузка сканов в программу:

Просто перетащите файлы в главное окно программы и подождите, 
пока они появятся в дереве объектов.

После загрузки сканов:
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Создание новой группы
Создайте новую группу (папку), как показано ниже (команда Create folder в 
контекстном меню):

 
Выделите все сканы в дереве (см. раздел Выделение объектов в списке).

Перетащите их в созданную папку.
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Удаление лишних участков
С помощью вращения и приближения вида (см. Простое 

перемещение вокруг модели) выставите модель как показано на 
рисунке (перпендикулярно виду):

Включите инструмент Выделение прямоугольником.

Выделите объект, как показано на рисунке ниже (см. Инструменты 
выделения):
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Откройте диалог Edit selection:

• кнопкой  в панели инструментов справа или

• через меню Tools → Edit.

Нажмите кнопку Invert (Инвертировать выделение).

В результате будет выделено все, кроме самой модели, как показано на 
рисунке ниже:
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С помощью кнопки Delete selected удалите выделенный участок.

Приложение удалит все части модели, кроме объекта.
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Локальная сшивка

Примечание
Локальную сшивку есть смысл применять, когда сканирование 
происходило без меток. Т.е. сканы расположены в хаотичном 
порядке, примерно как на рисунке ниже.

Откройте диалог Registration:

• кнопкой  через панель инструментов или

• меню Tools → Local registration.

Примечание
Для Вашего удобства не закрывайте окно Registration в процессе 
локальной сшивки. Не забывайте менять параметры!

Шаг 1
Оставьте только два скана остальные скройте, для этого выберите все 
сканы, которые Вы хотите скрыть (см. Выделение объектов в списке), 
щелкните правой кнопкой мыши по выделенным сканам и нажмите Hide.
Шаг 2
Выберите в папке с Вашими сканами, один из видимых сканов и нажмите 
кнопку Select as moved в диалоге. Выберите в папке с Вашими сканами, 
другой видимый скан, который вы хотите подшить к предыдущему, и 
нажмите кнопку Select as target.
Шаг 3
С помощью инструмента Navigation window выровняйте сканы, 
относительно друг друга, чтобы у них было несколько точек 
соприкосновения, как на рисунке ниже (см. Перемещение объектов).
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До выравнивания После выравнивания

Шаг 4
Выставьте параметры как на рисунке ниже и нажмите кнопку Local 
register.

Примечание
• Maximal distance, mm – максимальный диапазон поиска 
сканов, которые будут учитываться при сшивке.
• Plane-point max distance -  максимальное расстояние 
между точками на различных сканах.
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После выполнения операции появится окно со средней ошибкой сшивки.

Нажмите Ok. Выбранные сканы должны проникнуть друг в друга, как 
показано на рисунке.

Шаг 5
Введите параметры в окне Registration, как на рис. ниже: 

Нажмите кнопку Local register.
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Средняя ошибка: 0,028903

Шаг 6
Повторите операцию с теми же параметрами.

Средняя ошибка: 0,028902

Шаг 7
Измените параметры, как на рис. ниже:

Нажмите кнопку Local register.

Средняя ошибка: 0,028850
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Можно повторить эту операцию еще несколько раз (обычно достаточно 
двух раз), ошибка сшивки должна уменьшиться, а сканы будут проникать 
все больше друг в друга.
Конечный результат должен выглядеть примерно так:

Шаг 8
Создайте в папке со сканами вложенную папку и поместите туда сшитые 
только что сканы.
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Шаг 9
Далее необходимо подшить к созданной папке все остальные сканы по 
очереди.
Выберите созданную группу (на рис. выше она называется locreg). В окне 
Registration нажмите Select as target.
Для каждого ещё не сшитого скана:

а) выберите скан, покажите его (щёлкните правой кнопкой мыши и 
выберите Show) и выберите его в диалоге (кнопка Select as moved);

б) выполните шаги с 3 по 7 для этого скана. В шаге 3 подвиньте его к 
уже выровненным сканам;

в) перетащите скан в группу с выровненными в списке объектов.

Внимание!
Папку locreg не обязательно выбирать каждый раз, главное – не 
забывать нажимать Select as moved для скана, который в данный 
момент подшивается.

В конечном итоге у Вас должно получиться как на рисунке ниже.

Внимание!
После локальной сшивки, необходимо выполнить глобальную.
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Глобальная сшивка
Глобальная сшивка выполняется в следующих случаях:

1. После локальной сшивки.
2. Если сканирование производилось с метками.

На рисунке ниже показана модель, сшитая по маркерам при сканировании 
(пример).

Откройте диалог Registration:

• кнопкой  через панель инструментов или

• меню Tools → Global registration.
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Выберите папку (группу) с Вашими сканами и нажмите кнопку 
Select as moved в диалоге.

Измените параметры как показано на рисунке ниже и нажмите 
кнопку Global register.

Через некоторое время появится сообщение с информацией об ошибках.

Средняя ошибка 0,0323484
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Можно повторить операцию еще раз, с теми же параметрами.

Средняя ошибка 0,0322206

Внимание!
В новой версии программы, была реализована новая  функция с 
указанием числа итераций глобальной сшивки. Это автоматизирует 
процесс и позволяет сразу задать необходимое число повторов.
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Примечание
• Iterations (max) – максимальное число итераций
• Min diff between iterations – Минимальное значение 
между результатами двух итераций, при котором программа 
останавливает сшивку.

Пример результата глобальной сшивки:

Обрезка краев
Откройте диалог «Edit selection»:

• кнопкой  в панели инструментов справа или

• через меню Tools → Edit.



Руководство: Обработка Стр. 23 из 32

1. Установите значение 2 в поле Max edge length (ширина слоя вдоль 
границы объекта).

2. Выделите слой (кнопка Select border).
3. Удалите его (кнопка Delete selected).

Упрощение моделей

Откройте диалог Edit selection:

• кнопкой  в панели инструментов справа или

• через меню Tools → Edit.
Выполните шаги:

1. В поле Max edge length введите желаемую точность упрощения.
2. Нажмите Simplify.

Резервное сохранение результата
После того, как работа по сшивке и обрезке проделана все 

обработанные сканы желательно сохранить в X-файл.

Внимание!
Программа ICP 3 загружает только X файлы, не используйте 
формат STL для резервного сохранения файлов.

Меню File → Save all сохраняет все объекты, загруженные в 
программу в один X-файл.
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Папка хранения результатов

Мы рекомендуем следующий подход. Создайте папку Result в 
папке Вашего проекта, как показано на рис. ниже:

Внимание!
Не сохраняйте результат в папку _Export, т.к. ее содержимое 
удалится при новом экспорте.

Откройте созданную папку и сохраните файл:
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Сохранение сканов в группу STL-файлов
Экспорт в STL производится командой File → Save set of STL files.
В появившемся диалоге сохранения создайте новую папку (для 

удобства), откройте ее.
Укажите имя файла, к которому будут добавляться цифры и 

нажмите Save.
Например, если указать в качестве имени MyScan, то программа 

запишет на диск файлы:
MyScan01
MyScan02
MyScan03
…
MyScanNN, где N –общее количество сканов.

Выравнивание модели по осям
С помощью панели перемещения выровняйте модель по осям координат.
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Внимание!
Выравнивание модели по осям улучшает скорость построения 
единой модели. Если модель не выровнять, это займет большее 
время, либо закончится неудачей.

Модель до выравнивания:

Модель после выравнивания:
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Построение единой модели 
В списке объектов выделите папку со сканами:

Выберите меню Tools → Union model, появится диалог Isosurface 
generation.
Далее следуйте указаниям (см. рис. ниже):

1. Нажимаем кнопку Select group.
2. В окошке Enter Value выставляем шаг сетки. В данном случае 0,3. 

Число выбирается, в зависимости, от того какой результат нам 
нужен. Чем меньше число, тем выше детализация.

3. Нажимаем Auto Fill (автозаполнение), во всех трех окошках Unit 
sizes автоматически проставляется введенное нами число. 

4. Нажимаем кнопку Generate.

По окончании процесса появляется окно, где показано время потраченное 
программой на генерацию единой модели.
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Единая модель будет сгенерирована там же, где расположены сканы. Для 
того, чтобы ее увидеть, следуйте указаниям на рисунке ниже:
1. Выделите новую модель в дереве.
2. Переместите ее в сцене, либо просто скройте папку со сканами.

Для того, чтобы показать сеточную модель:
1. Выберите модель в списке объектов.
2. Нажмите кнопку Wireframe view (Сеточная модель) в панели 

инструментов:
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Чтобы рассмотреть модель, можно включить подсветку:

Со включенной подсветкой сцена будет выглядеть так:

На рисунках ниже можно сравнить полученную модель при разных 
значениях Unit sizes (Шаг).
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Пример 1: Низкая детализация (шаг 1мм)

Пример 2: Средняя детализация (шаг 0.5мм)
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Пример 3: Высокая детализация Шаг 0.3

Особенности построения единой модели в ICP3

1. Равномерная сетка:

Кривизна поверхности не учитывается при построении сетки, 
поэтому для высокой детализации модель может получиться достаточно 
«тяжелой».
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2. Иногда алгоритм дает неточности, или ложные детали.
На примере ниже артефакты возникают из-за неправильно 

выставленного параметра threshold. Этот параметр должен быть в 3 раза 
больше, чем шаг сетки (unit size).

Должен быть 0.5 * 3 = 1.5мм, а он  5мм.

3. Сглаживание острых углов.
Из-за того, что сетка везде равномерная, зачастую приходится 

выбирать шаг сетки, при котором сглаживаются некоторые детали.

Сохранение модели в STL-файл
1. Выделите модель в дереве.

2. Откройте диалог Сохранить выделенный через File → Save selected.
3. Выберите расширение STL и нажмите Save.


	Понимание процесса
	Экспорт из RVScanner
	Интерфейс ICP3: основы
	Простое перемещение вокруг модели
	Инструменты выделения
	Выделение объектов в списке
	Перемещение объектов

	Основные функции ICP3
	Загрузка сканов в программу:
	Создание новой группы
	Удаление лишних участков
	Локальная сшивка
	Глобальная сшивка
	Обрезка краев
	Упрощение моделей
	Резервное сохранение результата
	Папка хранения результатов

	Сохранение сканов в группу STL-файлов
	Выравнивание модели по осям
	Построение единой модели
	Особенности построения единой модели в ICP3

	Сохранение модели в STL-файл


